NAT not working. Help!

Cody Robertson Staff asked 2 years ago

Hi,

I have 3 routers in GNS3. ONE TWO and THREE, placed in order.

TWO has NAT conf and yet I am unable to ping THREE (172.168.1.2) from ONE (10.0.0.1)

Following is the config on TWO.

TWO#sh run

Building configuration...

Current configuration : 1171 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname TWO

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

memory-size iomem 5

no ip icmp rate-limit unreachable

ip cef

!

no ip domain lookup

ip auth-proxy max-nodata-conns 3

ip admission max-nodata-conns 3

!

ip tcp synwait-time 5

!

!

interface FastEthernet0/0

ip address 10.0.0.1 255.255.255.0

ip nat inside

ip nat enable

ip virtual-reassembly

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 172.16.1.1 255.255.255.252

ip nat outside

ip nat enable

ip virtual-reassembly

duplex auto

speed auto

!

ip forward-protocol nd

!

!

no ip http server

no ip http secure-server

ip nat inside source list 10 interface FastEthernet0/1 overload

!

access-list 10 permit 10.0.0.0 0.0.0.255

access-list 10 permit 10.0.0.0 0.255.255.255

!

!

!

control-plane

!

!

mgcp behavior g729-variants static-pt

!

line con 0

exec-timeout 0 0

privilege level 15

logging synchronous

line aux 0

exec-timeout 0 0

privilege level 15

logging synchronous

line vty 0 4

login

!

!

end

TWO#[/SIZE][/SIZE]

2 Answers
Shnerdly Staff answered 2 years ago

Thanks for your question blackninja.

I'm afraid I don't have any idea at all what [i]"I have 3 routers in GNS3. ONE TWO and THREE, placed in order."[/i] means.

It sounds to me like you are trying to connect two subnets that are very far apart in number. What are you running for a Subnet Mask??

MoonPoint answered 2 years ago

Is router 3 configured to respond to pings? It won't matter how router 2 is configured, if router 3 isn't configured to respond to ICMP echo requests. Some can be configured not to respond.

Know the answer? Login or sign up for an account to answer this question.
Sign Up