LinkSYS Wireless-N Router Disconnects Repeatedly

IP Newbie asked 3 years ago

OK, I just bought a new Windows 7 laptop computer 5 days ago and a new LinkSYS Wireless-N Home Router (Model: WRT120N).

I installed the software disk that came with the router on the laptop computer, as nearly perfectly as I could but have had nothing but problems.

[i]First, I already had a Westell modem/router Model 6100 (sent by the phone company~ISP) which I have used & talked about on this forum repeatedly. It was/is the one device that my old computer is plugged into to access the internet. After I got it straightened out, it has worked flawlessly for a couple of months.[/i]
[b](Note: I DO have my modem firewall restrictions set pretty high, and this might be a problem)[/b]

Here's what I did (installing the LinkSYS router):
1) I made sure that all power to the computer, modem, and the new LinkSYS router was turned off;
2) I plugged one end of the new ethernet cable into the laptop's ethernet port;
3) I plugged the other end of the ethernet cable into the # 1 port of the LinkSYS router;
4) I plugged the old ethernet cable from the modem into the "internet" port of the new LinkSYS router;
5) I powered up the modem, router, and finally the laptop and inserted the LinkSYS software disk into the laptop's disk player, and
6) I followed the instructions exactly as the setup wizard instructed.

The installation seemed to work and I was able to go onto the internet, but the connection seemed to be very slow. I have later learned that the connection first gets established, but then it almost immediately loses the connection. The LinkSYS router (or maybe the Westell modem/router) then re-establishes the connection to the ISP. I know this to be true because the I have watched the IP address assignment get changed over and over again within a few seconds.

In fact, as soon as the connection to the ISP is re-established, I can load a page from a website (just barely) before the connection is dropped again. If I try to load another page right after, a new IP address gets assigned and the process starts over.

I've tried to manually configure the router a variety of ways (through [url]http://192.168.1.1/[/url]). The number one thing I did was to make sure the connection is set to PPPoE (DSL). There are other things I have messed around with like the DHCP routing, as well as setting the connection to "stay alive," rather than the "on-demand" setting.

The Westell modem/router has it's own DHCP, and so does the LinkSYS router. I did experiment with disabling the LinkSYS DHCP, but haven't tried doing the same on the Westell modem/router yet.

I have also manually reset (the red button) the LinkSYS router several times to clear it's memory and start over fresh.

[b]One of the major things I checked for was to go back and look at my Westell modem's Security Log to see if some port or address from the LinkSYS router was being blocked by the Westell modem's firewall. What I saw on the logs has confounded me. The inbound traffic (coming from the LinkSYS router) shows only one IP address: 0.0.0.0 & the outbound traffic shows: 255.255.255.255. They were shown to be ALLOWED.[/b]
[i](note: I may that that backwards on the inbound/outbound~didn't write it down).[/i]

There were no other IP addresses listed on the Westell modem's Security Log, not even the normal 192.168.1.10 IP address coming from my computer to the Westell modem. Also, there were no IP addresses listed, such as the websites that I did manage to connect to briefly.

Previously, all connections made to other IP addresses had been logged on my Westell modem's Security Log, as well as local traffic between the computer and the modem. What is the deal with only 0.0.0.0 and 255.255.255.255 coming from the LinkSYS router?

This stuff is extremely confusing. Can somebody help out on this?

1 Answers
wimiadmin Staff answered 3 years ago

This should be a quick fix.

If the local IP of the westell modem is 192.168.1.x you'll need to either disable the router function of the new linksys or put it on a separate block.

Your cables are connected correctly.

Let's deal with just the linksys for a bit. Plug only your laptop in to the linksys and connect to it by going to the [url]http://192.168.1.1[/url]. On the setup page, change the network from 192.168.1.x to 192.168.2.x. Once it resets, you'll have to connect by going to [url]http://192.168.2.1[/url].

You won't need to set up PPoE on the linksys as the westell handles the connection to the internet. I suggest setting that to static and assigning it 192.168.1.2 subnet 255.255.255.0 gateway and dns should be the IP of the westell...most likely 192.168.1.1.

Turn off dhcp on the westell and leave the dhcp on for the linksys.

Plug in the westell to the internet port on the linksys, give it a few seconds, and all should work.

Know the answer? Login or sign up for an account to answer this question.
Sign Up