Can’t seem to open port for camera

IP Address Questions and AnswersCategory: Port Forwarding QuestionsCan’t seem to open port for camera
Felix SILINOU KAMDEM asked 2 years ago

Hi,
I have an IP camera (SDETER). It's connected by cable to my router. 
My router (DLINK DSL-2740U) is connected to ISP by WAN. My isp is Bouygues. 
I want to be able to view this camera from outside (ie: when I'm at work) by going to http://(my real ip) : (port). Port that I use is 88. I can't seem to do this.
First I set the port 88 to the camera's config and a Static IP address 192.168.1.15. I can see the camera when I'm at home (going to 192.168.1.15:88). In my Dlink router (192.168.1.1) I created a port forwarding rule with a single-port forward 88 UDP and TCP to 192.168.1.15.
I check the port using both Telnet, [url removed] and [url removed] but it is either closed or it says "I could not see your service on (my real ip) on port (88)"

I then enabled the dmz to 192.168.1.15 -- this doesn't solve the problem either. Same error as above.So I disabled dmz.
I desactivated my private firewall on windows and my port is still close. 
I desactivated my antivirus but the port is still closed. 
I used different port and static address but the port is still closed.
Any ideas?
I do not know what to do, so please help me. I provide all the screen shots
 

Thanks.

17 Answers
Best Answer
wimiadmin Staff answered 2 years ago

"We are unable to connect to the network. We apologize for the inconvenience". This could mean that you also need to forward another port for video. Even though two ports may be required, the camera port would still be the one used when attempting to connect. As for the http://publicIP:port working while you're on your own network, that's the same as going to http://localIP:port while being on your own network. Since the connection doesn't have to leave your network to resolve your request, the test would be inconclusive. When testing http://publicIP:port, you should always test from an outside connection like your 4G device.

wimiadmin Staff answered 2 years ago

If it's working when the camera is in the DMZ, then something is not right with the port forwarding on the D-Link. Leaving the camera in the DMZ is not ideal, but may not be a big security risk unless the camera is vulnerable to hacks.

Felix SILINOU KAMDEM answered 2 years ago

I was not clear on this. It works on DMZ, but only when I am in my local network. 
What I mean is that, on my local network with DMZ open, both http://@publicIP:port and http://@localIP:port works. And it still does not work when I am using an external network such as my 4G on my cell phone.
 

Felix SILINOU KAMDEM answered 2 years ago

I change my ISP box. I made the same configuration as before as with same result. When I configure only the port forwarding on my local network, http://@publicIP:port get me access on the Web Camera setting interface but the video is not working showing up. I get following message: "We are unable to connect to the network. We apologize for the inconvenience".

Felix SILINOU KAMDEM answered 2 years ago

You are right, I open the RTMP port of the camera and while I was connecting on my local network both http://publicIP:port and http://localIP:port work. 
But the port forwarding still does not work. Even the DMZ does not allow me to connect to the Camera from external network. Normally with DMZ only open, I should have been able to access the camera but why it does not work? 

Felix SILINOU KAMDEM answered 2 years ago

It works perfectly. I open both RTSP and RTMP port

wimiadmin Staff answered 2 years ago

That’s great! However, if you’re still not able to connect externally, it’s time to contact your ISP to see if they’re blocking your inbound traffic.

Know the answer? Login or sign up for an account to answer this question.
Sign Up