Can’t seem to open port for camera

Felix SILINOU KAMDEM asked 10 months ago

Hi,
I have an IP camera (SDETER). It's connected by cable to my router. 
My router (DLINK DSL-2740U) is connected to ISP by WAN. My isp is Bouygues. 
I want to be able to view this camera from outside (ie: when I'm at work) by going to http://(my real ip) : (port). Port that I use is 88. I can't seem to do this.
First I set the port 88 to the camera's config and a Static IP address 192.168.1.15. I can see the camera when I'm at home (going to 192.168.1.15:88). In my Dlink router (192.168.1.1) I created a port forwarding rule with a single-port forward 88 UDP and TCP to 192.168.1.15.
I check the port using both Telnet, [url removed] and [url removed] but it is either closed or it says "I could not see your service on (my real ip) on port (88)"
Port Forwardin 1st Screen Shot
I then enabled the dmz to 192.168.1.15 -- this doesn't solve the problem either. Same error as above.So I disabled dmz.
I desactivated my private firewall on windows and my port is still close. 
I desactivated my antivirus but the port is still closed. 
I used different port and static address but the port is still closed.
Port Forwarding 2nd issue
Any ideas?
I do not know what to do, so please help me. I provide all the screen shots
 

Thanks.

17 Answers
Best Answer
wimiadmin Staff answered 10 months ago

"We are unable to connect to the network. We apologize for the inconvenience". This could mean that you also need to forward another port for video. Even though two ports may be required, the camera port would still be the one used when attempting to connect. As for the http://publicIP:port working while you're on your own network, that's the same as going to http://localIP:port while being on your own network. Since the connection doesn't have to leave your network to resolve your request, the test would be inconclusive. When testing http://publicIP:port, you should always test from an outside connection like your 4G device.

wimiadmin Staff answered 10 months ago

I bet your isp is blocking port 88. You’ve done all the steps, thank you for explaining so thoroughly. Try port 8080 or some obscure port like 25000 if you can change the camera settings to accommodate such ports.

Felix SILINOU KAMDEM answered 10 months ago

@wimadmin, where you able to see the screen shots?
I have tried port 9080, 7000 and 8000 ports and another IP Camera without success. I will also try the port 25 000 once this afternoon. Please, click on the two links below for a clear idea of the configuration I have made:

  1. https://ibb.co/mxAHZn
  2. https://ibb.co/g5uBun

Nevertheless, this is the process I have used.

  1. I configured a static IP and Port on my camera's page setting on my browser using its IP address
  2. Access my camera from IE using the new and fixe IP Address and port
  3. I configured the port forwarding on my router as shown by clicking on the above link.
  4. I desactivated my firewalls

Is there a specific information I should provide?
Thank you very much in advance.

Felix SILINOU KAMDEM answered 10 months ago

There is something that I have noticed, using:

  • IP Camera Tool, it shows that the port is 88 but using
  • Advanced Port scanner, it shows that the port (TCP) 88 is httpd, so I don't know if it can be the reason why the port forwarding is not working

You can see the screen shot here: https://ibb.co/mxuZKx

wimiadmin Staff answered 10 months ago

Very odd. Thanks for the screenshots, they're really helpful. The httpd is most likely how the interface is hosted on the camera so I wouldn't worry too much about that...especially since the camera is working internally on your local network. IMO, this is 100% a port forwarding issue.

Is there a device in front of the D-Link or does the internet connection come straight to that router? If there's a modem in front of the D-Link, you may need to set up port forwarding from that device to the D-Link.

You may want to contact your ISP and ask if they block incoming ports? I've known ISPs to do this, but not all ports like you're running into.

Felix SILINOU KAMDEM answered 10 months ago

@wimiadmin, port 8080 is blocked, I cannot even configure my camera with it.
Port 25000 works fine but the port is still not open.

Thank you once again for your help.

Felix SILINOU KAMDEM answered 10 months ago

My router is indeed connected to my ISP, so I connect my camera directly to the cable coming from the ISP and created a port forwarding rule in my ISP equipment:  https://ibb.co/mtyQBc and it still dos not resolve the issue. 
Do you think my ISP may have an issue?
 

wimiadmin Staff answered 10 months ago

Yeah. That definitely sounds like your ISP is blocking all incoming port requests. Blocking all ports is a little unusual. I’ve only dealt with ISPs who usually block common ports and that makes sense for a number of reasons.

Felix SILINOU KAMDEM answered 10 months ago

I have restaure many time and redo the configuration. When connecting to by bbox, the link http://publicIP:port works and I can access my camera, but when I do from my cell phone it does not work at all.

Felix SILINOU KAMDEM answered 10 months ago

What I am saying is that:

  • when connecting on my ISP network directly both http://publicIP:port and http://localIP:port work and
  • when connecting on an external network, it does not work.

Since from the forum people with the same ISP do port forwardin for PS4 and Xbox I think that it is most likely a material issue. I will contact my ISP tomorrow

Felix SILINOU KAMDEM answered 10 months ago

And it only work when I have a DMZ on the local camera IP address setted up.

Know the answer? Login or sign up for an account to answer this question.
Sign Up