Can’t ping my home ip from an external location

turtlebrain asked 2 years ago

Perhaps this is just coincidence, but last week we had a freak snow storm knock out our power for a couple of days at my home. Ever since then I have not been able to connect via vpn client to or from my work computers.

One of the symptoms I've noticed is that I cannot ping to my home ip address from either work or from a remote server via ssh. I have internet access out, just not back in. Not only do I do the web development but also tech support where I work, so I need to be able to access all pc's in our 5 stores. I've also tried to connect via vnc and ssh with failure. This all worked just fine up until the snow storm.

I'm on comcast cable and have the same ip as for a very long time. Comcast tells me that they can ping to my modem. But other than that the 2 idiots I spoke with last night couldn't even tell me what time it was, never mind actually solve anything. To me, the ping problem is just a possible indicator of what the problem is.

I have both Linux and XP Pro computers at home and at work. At home, I tried bypassing the Linksys router by connecting directly from the modem to each of the computers with the same result. Can get out but not back in. No pings to here possible. Traceroute also will not complete. The VPN client will not connect in any case.

I'm assuming this to be a comcast issue and hopefully today I'll get to speak to an intelligent person there. (Yes, comcast does actually have a few that know what they are doing.) Did something go bad in my modem? In the mean time, I sure would appreciate any suggestions from folks here though.

Edit> Spoke again with comcast this morning. They again tell me that all appears to be fine from their end. I just happened to ask what ip they were showing for me, and it is not the same as what my router or THIS site indicates.

1 Answers
wimiadmin Staff answered 2 years ago

I think your problem is definitely with the Comcast modem.

I have a Comcast business account and my Comcast modem is also a router. Is your Comcast modem the same or is it more of a passive modem where you don't have to open ports on it to allow inbound traffic?

Do you have a reset button on the router to take it back to factory settings?

If it already went back to factory defaults, and it has a built in firewall, perhaps by default the firewall is turned on. But, if you've never had to turn the firewall off in the past, this probably isn't the problem.

If none of the above solutions are the fix, it seems as though there is a DNS problem on Comcasts end pointing any requests for your IP to you.

On another note, my Comcast modem/router shows 2 IPs. This is so they can control it from their end. When they manage the router, they come in on one IP...and if they can get to your modem on that IP, then everything would appear normal to them.

Not sure what it would take to get them to reset their IP routing tables. It'll automatically update at some point.....just not sure when.

You're at the mercy of Comcast. That sucks.

Brian

Know the answer? Login or sign up for an account to answer this question.
Sign Up